Requirements

PageLines DMS has some system requirements you should be aware of prior to installing.

Browser Requirements

PageLines DMS has been designed to work best in the latest desktop and mobile browsers, meaning older browsers will likely not be compatible, as they do not support most CSS3 properies. Specifically, we support the latest versions of the following:

  • Chrome (Android, iOS, Mac and Windows)
  • Safari (iOS and Mac only, Windows has more or less been discontinued)
  • Firefox (Mac, Windows)
  • Internet Explorer
  • Opera (Mac, Windows)

Internet Explorer 8 and 9

Internet Explorer 8 and 9 are compatible. However, please be aware that many CSS3 properties are not supported by IE8 and therefore, support for IE8 is limited.

To ensure you have a secure and enjoyable browsing experience, we recommend you visit Browse Happy. Browse Happy is a way for you to find out what is the latest version of each major browser.

DMS Visual Editor & Toolbar

PageLines DMS Visual Editor is only compatible with Google Chrome. The reason behind this is that Chrome has the best compiler and fastest javascript. Therefore if you wish to use the PageLines DMS Visual Editor, Google Chrome is required.

Server Requirements

PageLines DMS has been designed to work with any modern server environment, the recommended minimum requirements are:

  • PHP version 5.2.4 or greater (5.3 or greater recommended)
  • MySQL version 5.0 or greater

Users of PHP version 5.2

First and forth most, we recommend contacting your web host provider and ask them to upgrade your PHP version. If this isn't possible for whatever reason, please make sure Magic Quotes is off and Posix is Enabled/Installed.

A PHP memory limit of 49MB is the minimum requirement for PageLines DMS. However, this value can change depending on the version of PHP installed on your server. Below, is a list of the allocated PHP memory used by DMS for each PHP version.

PHP Version Memory Usage
PHP version 5.2 49MB (Megabytes)
PHP version 5.3 39.2MB (Megabytes)
PHP version 5.4 30.8MB (Megabytes)
PHP version 5.5 Recommended 14MB (Megabytes)

WordPress Requirements

We strongly advise that you always use the latest stable version of WordPress for security reasons.

  • The self hosted version of WordPress available from WordPress.org
  • WordPress version 3.0 or greater